Splitting Thingy

The class with the horrible name, Thingy, is growing. And I think it's time to have a look at it to see if there's something I can do about it.

Here's what it looks like.

public class Thingy : ApplicationContext
{
private ISongsView View { get; set; }
private Action<ApplicationContext> CloseAction { get; set; }
 
public Thingy(ISongsView view, Action<ApplicationContext> closeAction)
{
View = view;
CloseAction = closeAction;
}
 
public void ShowView()
{
View.OnViewClosed += () => CloseAction( this );
View.Songs = new ReadOnlyCollection<Song>( new List<Song>());
View.OnCloseButtonClick += View.CloseView;
View.ShowView();
}
}

All the interesting code is in the ShowView() method. It does four things:

  • Make sure that the application closes
  • Initialize the view
  • Attach listener for a button click in the view
  • Show the view

There's a clear grouping between the four lines. The first one has to do with application life-time while the last three have to do with showing the songs window. So I would like to split those responsibilities.

One could argue that the first line also has to do with the songs window. While it does, it is for a different reason. That line is actually interested in whatever window happens to be the main window, or the parent of all other windows. If I would change that to be another window I would have to change the first line while the last three lines would remain unchanged. That is, they change for different reasons.

Do you remember the Single Responsibility Principle (SRP)? There should never be more than one reason for something to change. This suggests that the Thingy class should be split right here.

The three last lines have to do with showing the songs window, so I create a class called SongsShower, into which I move the lines.

public class Thingy : ApplicationContext
{
// ...
 
public void ShowView()
{
View.OnViewClosed += () => CloseAction( this );
new SongsShower(View).Show();
}
}
 
public class SongsShower
{
private ISongsView View { get; set; }
 
public SongsShower(ISongsView view)
{
View = view;
}
 
public void Show()
{
View.Songs = new ReadOnlyCollection<Song>( new List<Song>());
View.OnCloseButtonClick += View.CloseView;
View.ShowView();
}
}

Also, I think it's time to rename Thingy into something more appropriate. It seems to be some kind of application lifetime manager. It decides what should happen when the application starts and when the application should close. The best name I can think of right now is Application, so I give it that name for now.

Also, I rename ShowView() into Start() since starting the application seems more like what the method does rather than just showing the view.

public class Application : ApplicationContext
{
// ...
 
public Application(ISongsView view, Action<ApplicationContext> closeAction) { ... }
 
public void Start() { ... }
}

The tests are still green, and running the application works fine, so I check in the code.

Leave a Reply

Your email address will not be published. Required fields are marked *

*

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>